Version 4.1
CONTENTS

Introduction  
Description ................................................................. 4
SoftONE-CNC Features ......................................................... 4
What's new in V4 ............................................................... 5
Installation & License ......................................................... 5
Technical Support ............................................................. 6

Operation Procedure  
Aveva (Tribon) nesting  
Aveva nesting preparation .................................................. 6
NC code generation ............................................................ 8
Edit Nesting functions ....................................................... 8
Inserting a nesting sketch .................................................. 9
Settings of controller and options files ................................ 10
NC Bevel Code ................................................................. 10

CAD DXF (Autocad) nesting  
How SoftONE-CNC Organizes CAD Geometry ......................... 11
Nest Preparation within a CAD software ................................ 12
Nesting .............................................................. 12
NC code generation ........................................................ 12
Edit Nesting functions ....................................................... 14
Inserting a nesting sketch .................................................. 14

Back plotting of NC file .......................................................... 16
Step by step simulation ...................................................... 16
Conversion of NC files ....................................................... 16

Basic Functionalities  
Operation Basis ................................................................. 18
NC Code Generation steps ................................................... 18
Default Processing and Error Correction ................................. 18

KERF Tool compensation .................................................. 19

Nesting sketch generation ................................................... 20

Nesting Edit features ........................................................ 21
Change Part ................................................................. 21
Change lead ................................................................. 22
Change Material ........................................................... 23
Automatic Position of nested parts .................................... 23

POST-PROCESSOR settings ................................................. 24
Apendix

File Menu........................................................................................................... 28
Open Nest NCE ................................................................................................. 28
Open GEN......................................................................................................... 28
Open DXF........................................................................................................... 28
Back-gen NC Code ............................................................................................ 28
Batch processing............................................................................................... 29
Save NCE.......................................................................................................... 29
Save NC code..................................................................................................... 29
Save Plate as DXF.............................................................................................. 29
Save Sketch as DXF............................................................................................ 29
Save All.............................................................................................................. 29
Print .................................................................................................................... 29

Edit Menu......................................................................................................... 30
Part/Shape .......................................................................................................... 30
Plate..................................................................................................................... 30
Lead..................................................................................................................... 30
AutoPosNo........................................................................................................ 30
Text

View Menu....................................................................................................... 31
Zoom In .............................................................................................................. 31
Autoscale.......................................................................................................... 31
Pan....................................................................................................................... 31
Repaint............................................................................................................... 31
Part Explorer..................................................................................................... 31
Info Bar............................................................................................................. 32
Toolbar ............................................................................................................. 32
CNC Code.......................................................................................................... 32
Simulate............................................................................................................ 32

Generation Menu ........................................................................................... 32
Complete Path.................................................................................................. 32
Marking Path..................................................................................................... 32
Cutting Path....................................................................................................... 33
Kerf Compensation .......................................................................................... 33

Tools Menu....................................................................................................... 33
Dimension....................................................................................................... 33
Shape Info....................................................................................................... 34
Nesting Sketch.................................................................................................. 34
Preference......................................................................................................... 35
Option................................................................................................................ 35

Context Menu.................................................................................................. 36

Main Display Window .................................................................................... 36

Information window ...................................................................................... 37

Tool Bars ........................................................................................................... 37
**SoftONE-CNC**

**Description of application**

SoftONE-CNC generates NC-code from **Aveva Marine (TRIBON)** software CAM “gen” files and **AUTOCAD** “dxf” files for computer controlled burning machines with plasma arc cutting, gas cutting, laser cutting and other manufacturing applications.

SoftONE-CNC is designed to run in Windows Vista/XP/7. The new graphical user interface (GUI) is based on last .NET technology with Microsoft user blue style interface for make it easy to learn. A new user can produce reliable NC-code within the first ten minutes of using SoftONE-CNC.

SoftONE-CNC offers the following main features:

- Converts **Aveva Marine (TRIBON)** “gen” CAD files to reliable NC-code for 2 axis cutting machine from Tribon Nesting and Panel Line Control modules;
- Converts **CAD “dxf”** files to reliable NC-code for 2 axis cutting machine from Autocad and other CAD systems;
- Converts NC codes from ESSI standard to G-Code standard and vice versa via **back plotting** function;
- Converts NC codes back to DXF files via back plotting function
- **Back plotting** of NC code function (NC Viewer);
- Cut width compensation – kerf compensaton- compensates for cutter or flame diameter for accurate sizing
- Automatic error correction features;
- Automatic path generation;
- Automatic position numbering;
- Automatic Production Nesting sketch generation;
- Advanced nesting edit tools: material selection, lead in/out edit, move pierce point, part delete;
- Manipulation of “V” bevel codes (from tribon files);
- Easy to learn graphical user interface;

**SoftONE–CNC features:**

- Works like a graphical NC postprocessor for Tribon and Autocad users
- Read and convert to NC codes bevel instruction from Tribon “.gen” files
- Read and convert to NC codes Autocad DXF files or other software which can export DXF files.
- Kerf tool compensation NC code calculation function - according to the user input kerf value (can be used also by CNC machines manufacturers for calculation of their machine tools compensation);
- Separating process entity by colors
- Export nesting plates to Autocad DXF connecting the geometries on different layers and colors for each process.
- NC code analyzing (ESSI and G-Code) and “step by step” simulation through “Back generation” of NC code function (NC code viewer and CNC processes simulation)
- Back NC code conversion to DXF files
- Read and convert NC code from ESSI to G-Code and vice versa according to users customized SoftONE postprocessors.
- Open contour offset - Allows for single lines to be cut
- All duplicate entities, i.e. identical lines or arcs, are automatically deleted.
- Allows the user to set the lead-in and lead-out length independently. You can create NC-code with no leads, lead-ins only or lead-ins and lead-outs. Avoids damage to the edge of the part
- Interactive change of lead in/out length and angles;
- Interactive move pierce point (leads moving)
- Delete parts and leads;
- Material selection features;
- Manually and automatic updating of parts production information; Auto position numbers feature;
- Automatic generation of production nesting sketches;
- Quick personalize the nesting sketch according with the user needs;
- Optimize the complete path automatically from the DXF file for reducing the cutting time process. The shapes on each layer are processed from the bottom left corner to the upper right corner.
- Calculates the area of the processed parts, minus any holes. Generate a report for the nesting plate with all necessary information for production
- Simulate on the screen all CNC processes: marking, cutting, idle etc.
- Mark using rapid travel speed.
- Generate marking or cutting path only.
- Allow the user to set-up the input filters, extension of the output NC files, motion settings as well as bevel settings of the resulted file.
- Works with both standards :ESSI or G-codes with or without bevel

What’s new in V4

1) New GUI : Microsoft Office style user interface based on the last .NET Technology.
2) New Standard toolbars, Status Bars, Tree view for easiest functionality acces:
   - New info bar window: nesting info and production info;
   - New status bar - X/Y tool coordinates shown;
   - New simulation toolbar.
   - New CNC toolbar and CNC code list view
   - ON/OFF toolbars/part tree/infoobar functionality
   - New Parts information in Tree View: pos, thickness, block, part area
3) Improved zoom and pan functionality; new shortcuts functions: Z (zoom),S(autoscale),W(pan);
4) Nesting edit functions; “Right click” context Menu menu for easy selection of objects:
   - Automatic position numbering
   - Change Part Production info: Part name, position numbers, thickness
   - Interactive change the lead_in/out angle.
   - Interactive change leads length.
   - Delete lead
   - Delete Part
5) New Info functions: distance between points function, shapes information
6) Add SoftONE NC file format (.nce files saving mode)
7) Add Nesting Production Sketch

V4.1

- Interactive move leads (pierce points);
- Automatically detect parts at DXF import process; detect DXF errors;
- More than 4 x time faster NC generation algorithm;
- Keep the last DXF path for easy future save NC file.

Installation and Licenses

Installation of the SoftONE-CNC software can be performed very simple, launching setup.exe file from installation kit. Follow the information on the screen to complete the software installation. After installation, if the license file is missing, the application will works in DEMO mode. Licenses of SoftONE-CNC use a licence file. After acquiring of the application, a received license file should be copied in the installation directory.
Technical Support

ONESoft offers all customers free technical support for the first year after purchase. Additional support is available through the maintenance and support program. In some cases our staff will offer to investigate the problem with your data file. In this case, we advise that you compress the data file (for example with WinZip) and e-mail it to us. We will investigate the problem and forward a solution to you.

Operation procedures:

1) Aveva/Tribon software operation [http://www.aveva.com]:

The main application workflow is as follow:

a) Nesting Preparation with Tribon/Aveva Software

Nesting files should be prepared in advance with Aveva Nesting module. After arranging the nesting parts, run "Verify" function. The system will generate the eNC Tribon "gen" files. For each nesting plate Tribon will generate a "gen" file.

Open the desired "gen" file with Soft-One-CNC application. In the left side the part explore tree view will be populated with the nested parts name and its position numbers. The "part explorer" tree view is useful for easy identifying of the parts nested on the current plate. The status bar will show the production information according to the nesting plate.

For detailed views, standard views functions are available: Zoom, Pan and Autoscale.

For parts with bevel sides, the color of the corresponding segments are shown with "Cyan" color.
For generation NC codes from Aveva (Tribon) files:

1) Start softONE-CNC application

2) Select File -> Open GEN

3) Browse “gen” folder and open the desired file;

4) The file is loaded and the Part Explorer shown the nesting parts.

5) Select the preference file from Tools -> Preference menu

6) Select Generation -> Generate Complete Path from the menu or click . During path generation, progress bars indicate the progress of the operations. After completion, the entire path is displayed and a preview of the NC code can be viewed in the “NC Information” toolbar. Also a detailed preview of nesting code can be viewed from menu: View -> CNC view function. “Distance” function from Tools -> Dimension -> Distance and “Info object” functions from Tool -> Shape info are also available after this step.

7) Select View -> Simulate. Press “play” button for viewing the machine paths. The parts are drawn in the order which will be cut;

8) Click “exit” from cancel the simulation mode;

9) Save the NC files : File -> Save NC code or click the corresponding toolbar item.

For quick files post processing, a batch generation function are available: File -> “Batch processing”.

b) Edit the nesting file

The following nesting editing functions are available*:

1) Material selection: **Edit -> Plate -> Change Properties** Menu or clicking on corresponding edit toolbar item:
2) Part production information change: **Edit -> Part -> Change**
3) Delete parts: **Edit -> Part -> Delete**
4) Automatic position of the parts: **Edit -> Auto Pos No**
5) Text modify: **Edit -> Text**
6) Automatic position numbering can be used for easy generation of automatic positions of the parts: **Edit -> Auto Pos No function**.

* For detailed information about nesting edit functions, please see “Nesting Edit” section.
c) Inserting a nesting sketch

The nesting production sketch can be easily generated as follows:

1) Save the file as Softone “NCE” file type with File -> Save Nest NCE function;

2) Use Tools -> Nesting Sketch Insert function;

3) Browse for a nesting sketch template. A default nesting sketch can be found in “Sketch” folder in the application installation directory. The sketch file format is DXF, so a customizable nesting sketch can be performed according to your needs;

4) The sketch for the current opened nesting file will be generated. Production information and position numbers of the parts are automatically added;

5) Save the “NCE” file with File -> Save Nest NCE function;

6) Print the sketch file or export to DXF file with File -> Save Sketch as DXF function.

** For detailed information about creating the nesting sketch templates, please see “Production Nesting sketch” section.
d) Settings of controller and options files

The ‘Tools, Preference’ menu can be used for adjusting the output NC code (ESSI or EIA). The settings files are located in “def” folder of the application. The default files for CNC machines are “XML” files type. These files can be easily edited by the users and create new ones for the new machines types. SoftONE uses a controller code file for every type of controller to handle the variations. You can modify or make your own controller files with any text editor or XML editor to support any controller. Use a text editor like Write or Notepad to change the individual codes in a controller file. Just select the code that you wish to change and type in a new value for the specific code. It is good practice to open a file that represents your needs most closely and to save it under a different name and modify and save the settings through interface (Tools, Option sub-menu). Make sure also that “ControllerType” record is not empty and has one of the following values: “essi” or “eia”.

** For detailed information about controller settings, please see “Postprocessor options”.

In ‘Tools, Option’ menu you can change the color for the CNC processes. Also you can change the background color of the main application window.

e) NC Bevel Codes

SoftONE-CNC recognize the bevel codes used in Aveva nesting files and can generate the NC bevel code. For generation of bevel NC code, some settings available in the Preference -> Bevel page should be performed.

![Preference Settings](image)

For more details about this settings, please see the “Post-processor preference” section.
2) CAD “dxf” (Autocad) operation

The main application workflow is similar with Aveva “gen” nesting operations, but some important things should be taking into account:

a) How SoftONE-CNC Organizes CAD Geometry

Entities are the lowest level of geometric information. SoftONE-CNC presently supports the following CAD entities:

- lines
- arcs
- circles

If you use CAD blocks or polylines to group your drawing data, please explode them just before you write the DXF file. You can then use the undo command to restore the grouped state.

Leads are short straight lines at the start and end of a shape. They are used to avoid piercing directly on the edge of a part. SoftONE-CNC places leads automatically at the appropriate location of a shape. The cutting cycle is started at the beginning of the lead-in and terminated at the end of the lead-out; thus ensuring that a ‘dirty’ cut does not ruin the edges of the shapes.

Connectors are straight lines that connect the shapes with each other. Between cutting and marking, the burner head travels along connectors at high speed (fast travel). Connectors can be automatically created by SoftONE-CNC for you.

Shapes consist of a number of connected entities. Shapes may be closed, i.e. the end of the last entity connects with the start of the first entity, or a shape may be open. Closed shapes can be checked for direction of travel, i.e. clockwise or counter clockwise. Open shapes cannot be checked for direction. It is the operator’s responsibility to check the shapes. These paths will be deleted from the tool path automatically!

Layers are logical levels in a CAD drawing. They contain entities. SoftONE CNC assigns a meaning to each layer. The following default layer names are recognized by SoftONE. You can change the default layer names to suit your needs.

- MARK shapes are marked on the plate with a scribing unit.
- INSET shapes are OUTSIDE shapes cut from the waste inside through holes.
- INSIDE shapes are cut with the kerf towards the inside of the path. This layer is used for through holes.
- OUTSIDE shapes are cut with the kerf set towards the outside of the closed shapes.
- REFERENCE (PLATE) layer shapes are used to show plate edges, clamping information or text showing nest names. No processing occurs for reference shapes.

Entities on other layers are omitted.

b) Nest Preparation within a CAD Program

SoftONE-CNC converts DXF files to NC instructions for computer controlled 2D tables for plasma arc, gas burning, laser cutting, wood router, and others. You can use any CAD program that can export the drawing in DXF format and support layers. The CAD drawing has to meet certain specifications to be able to be processed. The operations described here are specific for using
SoftONE-CNC together with AutoCAD, but are essentially the same for any other CAD program that can export DXF files.

Steps involved:

1. Prepare the CAD drawings for all parts.
2. Nest the parts into a single drawing. This can often be done manually using AutoCAD or by a third party nesting program.
3. Explode all blocks and polylines that you might have in your drawings.
4. Export the drawing to a DXF file.
5. Use SoftONE-CNC to convert the DXF drawing to NC-code.

c) Nesting
You can use a third party nesting program or nest the parts manually. A skilled CAD person can nest the parts efficiently using AutoCAD alone. This manual procedure is often economical if the parts are complex and many different parts of greatly different complexity have to be nested, as it is often the case for shipbuilding.
Open a new drawing for the nest. Place one or more rectangles on the reference layer (plate layer) that indicates the size of your stock plates. Insert the all blocked parts randomly on the drawing. Nest the parts starting with the larger ones using the move and rotate commands until all parts are nested. You may want to place some parts in through holes, such as small brackets. All entities with outside cuts within a through hole have to be changed to the INSET layer. They cannot contain any inside cuts!

The resulting drawing contains all the required information to produce the NC-Code for a number of parts to be cut from one plate.

Before exporting the drawing to a DXF file explode all blocks and polylines! It is advisable to turn off or freeze all layers that are not required for NC processing. You can save disk space and time by writing just the entities to the file. When prompted by AutoCAD for 'Number of decimal places / (Entities)' enter 'E' ('O' for objects in AutoCAD 13) and select the entities by dragging a rectangle. This way only entities will be written and no header information. The resulting file will be lot smaller. However, the header information may be required if you want to read the DXF file back into a CAD program.

You can now use SoftONE-CNC to create NC-code for the nested drawing!

d) Start execution of SoftONE-CNC for generation of NC code with the following steps:

For generation NC codes from CAD DXF files:

1) Start SoftONE-CNC application
2) Select File-> Open DXF
3) Browse the folder where dxf nesting files are stored and open the desired file;
4) The file is loaded and the Part Explorer shown the detected parts.
5) Select the preference file from Tools-> Preference menu

5) Adjust the controller settings or create new one as necessary; (see also “Postprocessor preference” section for detailed information)
6) Add leads to all parts as necessary with “Add Leads starts” function.

7) Select **Generation > Generate Complete Path** from the menu or click. During path generation, progress bars indicate the progress of the operations. After completion, the entire path is displayed and a preview of the NC code can be viewed in the “NC Information” toolbar; Also, a detailed preview of nesting code can be viewed from menu: **View -> CNC view** function, “Distance” function from **Tools -> Dimension -> Distance** and “Info object” functions from **Tool -> Shape info** are also available after this step.

8) Select **View -> Simulate**. Press “play” button for viewing the machine simulation paths. The parts are drawn by machine processes order.

9) Click “exit” from cancel the simulation mode;

10) Save the NC files : **File -> Save NC code** or click the corresponding toolbar item.
e) Edit the nesting file

The following nesting editing functions are available:

1. Material selection: *Edit -> Plate -> Change Properties* Menu or clicking on corresponding edit toolbar item.
2. Part production information change: *Edit -> Part -> Change*
3. Delete parts: *Edit -> Part -> Delete*
4. Change Leads angles: *Edit -> Leads -> ADD LEADS STARTS*
5. Change leads length: *Edit -> Leads -> TRANSFORM LEAD*
6. Delete leads: *Edit -> Leads -> DELETE ALL LEADS*
7. Automatic position of the parts: *Edit -> Auto Pos No*
8. Text modify: *Edit -> Text*
9. Automatic position numbering can be used for easy generation of automatic positions of the parts: *Edit -> Auto Pos No function.*

* For detailed information about nesting edit functions, please see “Nesting Edit” section.

f) Inserting a nesting sketch

The nesting production sketch can be easily generated as follows:

1. Save the file as Softone “NCE” file type with *File -> Save Nest NCE* function;
2. Use *Tools -> Nesting Sketch* Insert function;
3. Browse for a nesting sketch template. A default nesting sketch can be found in “Sketch” folder in the application installation directory. The sketch file format is DXF, so a customizable nesting sketch can be performed according to your needs;
4. The sketch for the current opened nesting file will be generated. Production information and position numbers of the parts are automatically added;
5. Save the “NCE” file with *File -> Save Nest NCE function*;
6. Print the sketch file or export to DXF file with *File -> Save Sketch as DXF function*.
** For detailed information about creating the nesting sketch templates, please see “Production Nesting sketch ” section.
3) BACK Plotting and conversion of NC files

Back plotting of any NC files can be performed through of “back generation” function from “File” menu. The input NC files type should be in accordance with the selected controller type file from options menu. For example if a G-Code controller is selected in options menu, the function will import a G-Code according to the controller’s file.

For back blot of a NC codes the followings steps should be made:

1) Start SoftONE-CNC application

2) Select File-> Back-gen NC file

3) Browse the folder where NC files are stored and open the desired file;

4) The file is loaded by application and the NC paths are shown on the main screen

For conversion to other NC file format or NC format for a different controller settings:

5) Select the preference file from Tools-> Preference menu

6) Adjust the controller settings or create new one as necessary; (see also “Postprocessor preference” section)

7) Select Generation > Generate Complete Path from the menu or click the corresponding toolbar item. During path generation, progress bars indicate the progress of the operations. After completion, the entire path is displayed and a preview of the NC code can be viewed in the “NC Information” toolbar. Also a detailed preview of nesting code can be viewed from menu: View -> CNC view function.

8) Select View-> Simulate. Press “play” button for viewing the machine simulation paths. The parts are drawn by machine processes order.

9) Click “exit” from cancel the simulation mode;

10) Save the NC files: File->Save NC code or click the corresponding toolbar item.

After importing of NC file the following functions will be available:

a) Step by step simulation
With this function the user can view on the screen the entire processes from CNC machine. Through “simulation” toolbar items (start, step, stop functions) the user can analyze the NC code instructions and detect easy any possible problems.
b) “Generate path” function
Running “Generate complete path” function from Generation menu, the current NC imported file can be converted to other NC code according to the new or existing controller (postprocessor) selected file. The resulted NC file will be in accordance with the selected postprocessor file settings (ESSI or G-Code/EIA).

c) Export to DXF
With the “Save as DXF” function unde “File” menu, the imported NC file can converted back as DXF nesting plate file for future modification. All geometries in the resulted DXF nesting plate will be connected to dedicated layers according to the CNC machine processes for easy CAD nesting modification (OUTSIDE, INSIDE, MARK, PLATE). Any CAD software like Autocad can be used for modifying the converted DXF nesting plates. After modification, the nested plate can be imported back into SoftONE-CNC software like DXF nesting file, with “File Open DXF..” function, and generate the modified NC file accordingly.
Basic Operation Functions

1) Operation basis

You can use SoftONE-CNC for conversion your nesting DXF or Aveva gen files to NC code.
You can plan you projects, follow this procedure:

- Create a new folder for the project.
- Move all DXF nest files into the new directory.
- Open a DXF file and set up the preferences according to the requirements of the job. The preference settings will be saved in the DEF folder in the main application installation folder.
- Generate one small NC code file and check that it works on your machine.

NC Code Generation Steps:

The following steps are recommended for generating NC code:

- Open the DXF file.
- Optimize the path automatically.
- Check the lead placement and modify it if are necessary.
- Simulate the generated path.
- Save the NC code.
- Overlay the optimized cutting path in the DXF output file over the original nest and verify the path.

Default Processing and Error Correction Overview

SoftONE-CNC performs a number of default processing checks when reading or optimizing a path.
When reading the DXF file, SoftONE-CNC performs the following procedures:
- All entities on unspecified layer names (or colors) are ignored.
- Duplicate entities are removed automatically.

When optimizing a complete path, the following procedures are performed:
Detect all nested part according to the DXF layers;
All elements within the set snap tolerance are connected to shapes. A closed shape is a shape that has the same start and end location. That is, it encloses an area completely in one direction (clockwise or counter clockwise). Two entities are considered to be connected if the end points are within the specified snap tolerance.
- Entities below the Erase Elements < value are deleted.
- Lead-ins and lead-outs are automatically generated as specified and checked for the possibility that the leads intersect with the shape.
All shapes are sorted to produce an optimized processing order.
The fast travel connectors are generated automatically.
The total length of each processing type (marking and cutting) is calculated.
The total area of the processed parts is calculated.
- The processing is on a layer-by-layer basis when using Generation > Generate Complete Path.
The order of processing is:

1. Entities on the MARKING
4. Entities on the INSET layer
5. Entities on the INSIDE layer
6. Entities on the OUTSIDE layer
Marking
Shapes on the MARKING layers are processed with the scribing unit. Shapes on the MARKING layer have no specific direction. The rule is that scribing starts at the end of the marking shape that is closest to the X=0, Y=0 location. The next marking shape is processed from the end that is closest to the current scriber location.

Cutting
The shapes on all cutting layers are processed from the lower left to the upper right. Closed shapes on all cutting layers have a defined processing direction. Shapes on the INSET layer and shapes on the OUTSIDE layer can processed in a clockwise direction, while shapes on the INSIDE layer are processed in a counterclockwise direction. This results in the kerf always being to the left of the path. If SoftONE-CNC kerf function will be used, it will generate the kerf according with the preference settings.
Open shapes on the outside layer can be used to cut off an unused part of a partially used stock plate.

Leads
Leads are automatically placed at the lower-left corner of each shape. Leads consist of a lead-in and a lead-out. The opening angle between the lead-in and the lead-out is 25 degrees. The lead-in and lead-out start angle can be modified from preference menu. The leads always point in the direction of the kerf.
Kerf offsets the torch to one side of the path line by half the width of the cut. This ensures that the finished part will have the specified dimensions. For through holes, the kerf has to be on the inside of the hole; for outside shapes the kerf has to be on the outside of the shape.

2) KERF compensation NC code function

This function perform the calculation of the kerf compensation and can be accessed through: “Generation” , “Kerf calculation”. It useful especially for old CNC machines which the calculation of tool compensation take long time or CNC controllers which doesn’t have implemented kerf calculation function.
Most of CNC controllers perform the kerf calculation, so this function should be used only for controllers which doesn’t make kerf compensation or the calculation take too long time.
A new NC code will be generated according with the input kerf value. The kerf compensation value should be introduced by the user when it will be prompted by the application. A default value of 1.5mm is already stored in the preference setting XML file and will be proposed by default. The user can change this default value based on the plate thickness and CNC machine settings.

The function will calculate the new paths and will display on the main screen the old and new paths. NC code will be updated automatically with according with the new kerf paths.
This function is available for all type of input files: Aveva gen files, Autocad dxf and NC files. 
**Note:** for “dxf” and “gen” files, the function can be used after performing the generation of the NC file by the “Generation” , “Complete path” function.

3) **Nestig sketch generation**

Like for dxf nesting files, production nesting sketches files should be structured on layers and should the followings entities:

- lines
- arcs
- circles
- texts

SoftONE-CNC recognize the followings DXF layers

- NestForm : contain all form’s geometries;
- TEXT1: contain nesting sketch texts;

For automatically generation of production information, besides other texts objects, the followings texts keywords should be used in nesting form :

- “Nesting name” - nesting’s name
- “Plate length” – plate length
- “Plate width” – plate width
- “Plate thickness” – plate thickness
- “Plate quality code” – plate quality
- “Burning length” – cutting length
- “Marking length” – marking length
- “Total parts weight” – total weight

You can use any CAD program that can export the drawing in DXF format and support layers. The CAD drawing has to meet the specified rules in order to be able to be processed. The operations described here are specific for using SoftONE-CNC together with AutoCAD, but are essentially the same for any other CAD program that can export DXF files.
Steps involved:

1. Open default SoftONE-CNC nesting sketch stored in the sketch folder or create a new nesting form drawing;
2. Draw the nesting form according to your internal rules using standard drawings functions (e.g., arc, line, polyline)
3. Add the desired production info keywords on “TEXT1” layer;
4. Explode all blocks and polylines that you might have in your drawings;
5. Export the drawing to a DXF file;
6. Insert the nesting sketch into SoftONE-CNC nesting from Tools-> Nesting Sketch -> Insert menu or toolbar item. SoftONE-CNC will autoscale your current nesting and generate all production information and positions numbers.

A “Toggle Sketch/Nesting” function are available with Tools -> Nesting Sketch -> Toggle Sketch/Plate or . This function bring up on the main screen, the nesting plate or nesting sketch. Delete nesting sketch and exchange existing sketch can be also performed with Tools -> Nesting Sketch -> Delete and Tools -> Nesting Sketch -> Insert.

4) Nesting Edit features

The nesting can be modified before saving the final NC code. After each modification, the user should run “Generation->Complete path” function for update the NC code. If the nesting file will be saved as SoftONE NCE, it can be used later for other modifications or for generation of NC code for other controllers.

The following edit functions (Edit menu) are available:

1) Part
   - add/ change production information - position number, thickness, block number
   - delete – delete part
2) Transform leads
   - Angle – change the angle of lead in/out
   - Length – change length of lead in/out
   - Delete - delete lead
3) Plate – Change material
4) Auto Pos No
5) Text
   - Change
   - Height
   - Delete

1) Part

Properties. With this function you change the following production information:

Name : Name of the plate part
Position: position number of part
Thickness
Block – part block

For easy identification of the selected part, it will be highlighted on the screen. The part explorer will highlight also the name of the selected part.
After finishing the modification the part explorer is updated automatically with new production info.

**Delete**: This function deletes a part. First, the user should select the desired part. The part will be highlighted on the screen and part explorer. For deleting the part, "Execute" function should be performed. The NC code will automatically be updated.

2) **Transform leads**: This function performs interactive change of the lead in or lead out angles. After the selection of the lead (in or out), the user can change the angle with rotate function, (toolbar: ), change the length with length modify function (toolbar: ), move lead (pierce point) or delete the lead with delete function (toolbar: ). For moving the lead you should only select a new element of the part and press "execute" button.
For finalizing the operation, “execute ” function should be performed (toolbar: ). For cancel the modification, the “exit function” toolbar item should be clicked (toolbar: ).

NOTE: You should run “Generation -> AllPaths ” function for updating the NC code!

3) **Add Leads Starts** These functions add automatically all starts to detected parts (lead in/out).

4) **Change Material** This function change the plate’s dimension, thickness and quality of the nesting plate.

![Nesting Properties](image)

5) **Auto Pos No** This function perform an automatic positioning of the nesting plate parts. The user should input the start number.

![SoftONE CNC](image)

The system will update the position of the parts starting with the specified number. After finishing, the part explorer will be updated also with the new positions.

6) **Text** This functions will perform texts functions: modify content, change height, delete, Copy, Move.
7) POST-PROCESSOR preferences

In ‘Tools, Preference’ menu you can adjust the application settings and the output code (ESSI or EIA). The settings can be saved for future use. The settings files are located in “def” folder of the application. The default settings files are “XML” files, so can be edited by the user with a standard editor. For CNC controllers, the user can create new CNC settings XML files. The following XML default settings files are used:

- preference.xml – general nesting settings file;
- settings.xml – application settings file;
- “Machine_name”.xml – each machine read the settings from own XML file.

SoftONE uses a controller code file for every type of controller to handle the variations. You can modify or make your own controller files with any text editor or XML editor or through Preference menu to support any controller.

For creating a new machine XML file, you can copy an existing file with a different name in the “def” folder. You can modify it through Preference menu or edit manually the XML file.

**General:**

Postprocessor: select the desire postprocessor for output the NC files
Description: edit the description of the postprocessor
Output extension: modify the extension of the NC file
Burn Type: select the cutting type by selecting: Gas or Plasma
Code format Select the code format by clicking Incremental or Absolut
Controller type: Select the output NC code standard by clicking ESSI or G-Code

![Preference Menu](image)

**Preference Menu:**

- **Postprocessor:**
  - esst_def
- **Description:**
  - Esab Machine
- **Output Extension:**
  - .ncn
- **Burn Type:**
  - Gas
  - Plasma
- **Controller Type:**
  - ESSI
  - EIA (G-code)
- **Code Format:**
  - Incremental
  - Absolut
- **Units:**
  - Millimeters
  - Inch

**General:**

*Postprocessor:* select the desire postprocessor for output the NC files
*Description:* edit the description of the postprocessor
*Output extension:* modify the extension of the NC file
*Burn Type:* select the cutting type by selecting: Gas or Plasma
*Code format* Select the code format by clicking Incremental or Absolut
*Controller type:* Select the output NC code standard by clicking ESSI or G-Code
Input Filters

Maximum radius: set the max radius that are supported by your cutting machine. Check the controller's documentation for setting this value.

Snap tolerance: The length of the gap between elements of a shape that SoftONE will jump or connect into a single shape. This compensates for lines not actually joined in the original DXF files. Snap tolerance should be GREATER THAN or EQUAL TO the length set in Erase Elements <. SoftONE-CNC automatically adjusts two elements to the same meeting point. The program automatically determines which element has to be adjusted to close the gap causing the least change in the path.

Processing:
Rapid ON - the code to tell the controller to use fast travel for all further movements. Used for ESSI.
Rapid OFF - The code to tell the controller to stop a fast travel.
Plasma ON- The code to tell the controller to use the plasma tool and turn it on.
Plasma OFF- The code to tell the controller to use the plasma tool and turn it off.
Gas On The code to tell the controller to use the gas tool and turn it on.
Gas OFF The code to tell the controller to use the gas tool and turn it off.
MARK_ON -- The code to tell the controller to turn the marking head on. This can be punching, spray paint, inking, or zinc powder marking.
MARK_OFF -- The code to tell the controller to turn the marking head off.
MARKOFFSET_ON -- The code to tell the controller to offset the tool head for the marking head.
MARKOFFSET_OFF -- The code to tell the controller to turn the marking head offset off.
KERF_LEFT -- The code used to offset the torch to the left of the cutting path.
KERF_RIGHT -- The code used to offset the torch to the right of the cutting path.
KERF_OFF -- The code used to cancel the torch offset.

Processing settings are used during post-processing when generating the NC code. You can modify the instruction taking into account about the settings of your machine controller.

Leads

The outside leads (for outer contour) and inside leads (for holes) can be changed. For “0” value of lead in/out, you can switch on off the corresponding leads. You should take into account about the distance between parts when modify these values for avoiding the overlapping.
Bevel

Bevel settings are used during post-processing when generating NC code with bevel codes (from Tribon ‘gen’ files). You can modify the instruction taking into account about the settings of your machine controller.

For more information about bevel cutting instructions and settings, please send an e-mail to office@onesoft.ro

DXF Layers

DXF Layers can be changed accordingly to CAD geometries for each process from the CAD nesting DXF file. Default values are: MARK for marking, OUTSIDE for outer contour, INSIDE for holes, INSET for parts inside the holes.
APENDIX

Features
This section explains the individual menu commands.
The user interface consists of several bars and windows:
- Title bar
- Menu bar
- Toolbar
- Part Explorer tree view
- Display window
- Information window

Title Bar

The narrow bar at the top of the screen displays the name of the current file.

File Menu

Open Nest NCE  Ctrl+H
Open GEN  Ctrl+G
Open DXF  Ctrl+D
Back-gen NC-file...
Batch processing
Close File
Save Nest NCE  Ctrl+S
Save NC-code
Save Place As DXF
Save Sketch As DXF
Save ALL
Print  Ctrl+P
Print Setup
Exit

Open Nest NCE
Open NCE opens a file that has been saved in SoftONE-CNC format. Use this function to read
back a previous partially or fully optimized and saved NCE file. This function is useful when you
have to make further changes to a nest or if you just have to change the post-processor for a different controller. The NCY file is a snapshot of
the geometry at the moment when you saved the NC code if you used the Save All menu.
Open GEN
Open nested GEN file resulted from Aveva/Tribon Nesting module.

Open DXF
Open DXF opens a DXF file. The DXF file contains the nest for the NC code generation. The DXF file is imported and interpreted using the settings in Preferences. The DXF file has to conform to the SoftONE-CNC standards to be read successfully.

Back-gen NC file
Back gen NC Code opens an NC code file for backplotting. This function lets you load an NC code file and convert it back to geometry.

Batch Processing
Open multiple GEN Aveva nesting files and convert all in batch.

Close File
Close current opened file.

Save Nest NCE
Use Save NCE to save geometry in a special SoftONE-CNC format. Use this function to save the current state of manual or automatic optimization and the current modified nesting sketch. You can use this file later if you have to use a different controller without having to optimize and test the path again and without customize again the sketch. You can open the NCE file at a later date and save the NC code.

Save NC-Code
Save NC Code saves the complete path as an NC code file (path must be complete). SoftONE-CNC also saves a file with the extension .LST. This text file contains some pertinent information about the processed data file, such as the lengths of marking and cutting and the area of the process parts.

Save Plate as DXF
Save As DXF file saves the geometry as a DXF file format. This file can be overlaid onto the CAD drawing to check the path generation.

Save Sketch as DXF
Save the production nesting sketch as DXF file.

Save ALL
Save All saves as an NC code file, NCE file, and DXF file with the same filename (with the appropriate file extensions). This feature is provided so that when you want to save the NC code, NCE, and DXF formats you can provide a filename and all three formats will be saved with the same filename but their appropriate file.

Print
Select Print to print the current display to a Windows plotter or printer.
**Edit Menu**

<table>
<thead>
<tr>
<th>Edit</th>
<th>View</th>
<th>Generation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part/Shape</td>
<td>▼</td>
<td>▼</td>
</tr>
<tr>
<td>Plate</td>
<td>▼</td>
<td></td>
</tr>
<tr>
<td>Leads</td>
<td>▼</td>
<td></td>
</tr>
<tr>
<td>Bevel</td>
<td>▼</td>
<td></td>
</tr>
<tr>
<td>Auto Pos No</td>
<td>▼</td>
<td></td>
</tr>
<tr>
<td>Text</td>
<td>▼</td>
<td></td>
</tr>
</tbody>
</table>

**Part/Shape - Functions:**
- **Change** Modify the part data
- **Delete** Delete a part from nesting. The NC code is updated automatically when “Execute function” is performed
- **Plate** Change the plate material dimensions, quality and thickness

**Leads - Functions:**
- **Add leads starts:** add starts automatically to all detected parts
- **Transform:** interactive change the lead angle and/or the lead length.
- **Delete all leads:** delete all starts from the current nesting;
- **Auto Pos No:** Perform an automatic positioning number of parts detected in the current nesting. The system asks for input start number.

**Text - Functions:**
- **Insert:** Insert a text into current nesting sketch;
- **Change:** change a height of text
- **Delete:** delete a text from current nesting sketch
View Menu

<table>
<thead>
<tr>
<th>View</th>
<th>Generation</th>
<th>Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom In</td>
<td>Z</td>
<td></td>
</tr>
<tr>
<td>Autoscale</td>
<td>S</td>
<td></td>
</tr>
<tr>
<td>Pan</td>
<td>W</td>
<td></td>
</tr>
<tr>
<td>Repaint</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parts Explorer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Info Bar</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toolbars</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CNC Code</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Simulate</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Zoom IN**
Zoom magnifies a selected area. Select the area by dragging a zoom window enclosing the area to magnify (the hot key for this function is Z).

**Pan**
Pan moves the drawing about the screen (hot key W).

**Zoom All**
Zoom All displays the entire drawing on the screen (hot key A).

**Repaint**
Refresh the current drawing.

**Part Explorer:**
Show or hide the part explorer tree view which contains detected nested parts.
Info bar
Show or hide the info bar situated at lower bottom side

Toolbars
Show or hide the application Toolbars: Standard Toolbar, NC Information Toolbar, Edit Toolbar

CNC Code
Bring a new window on the screen with NC code for easy visualization of NC Code

Simulate
Simulate the machine paths on the screen:

Play, Stop, Step toolbar buttons are available for easy analyzing of NC code.

Simulate
Simulate draws the path slowly. The following window appears at the bottom of the screen.

Generation Menu

Complete path
Generates a path and optimizes the nest completely. This function invokes the following procedures:
- Erases duplicate entities.
- Removes short elements as specified in Preferences.
- Sorts shapes.
- Optimizes shapes on the marking layer.
- Generates lead-ins and lead-outs for all cutting shapes using the values set in Preferences.
- Generates the fast travel connectors.
- Calculates the number of shapes on each layer.
- Calculates marking and cutting lengths.
- Calculates the area of the processed shapes.

Marking Path
Similar with “Complete path” but generate only the marking paths.
**Cutting path**
Similar with "Complete path" but generate only the burning(cutting) paths.

**Kerf Calculation**
Generate the tool offset path. This function create a parallel contour for all geometries on the cutting layer at specified kerf value. The parallel tool offset contour will be calculated for the input kerf value divided by 2.
For detailed information about kerf function, please see the “Kerf Calculation” section

**Tools Menu**

![Tools Menu Image]

**Dimension : Distance**
Perform a distance calculation between 2 points.

Information displayed: distance between points in mm, delta X, delta Y.

**Shape Info**
Show information about selected object in a “InfoTool” window. First, user must select a geometry.
Information displayed: Part name, shape type, Start/End Points, Bevel type/side

**Nesting Sketch**

- **Insert:** Generate a sketch for current nesting. Toggle button between plate and sketch can be used for easy display of the nesting plate or drawing sketch.
- **Delete:** Delete the current nesting sketch
- **Toggle Sketch/Plate:** Show the nested plate or sketch on the main application window

**Preference:**

Show the application preference window for change the application and controller settings.

For detailed information about preference functions, please see “Post_Processor settings” section.
Option

Show the option settings window.

![Options Window]

Idle : change the color used for display on the main screen for idle geometries layer.

Marking : change the color used for display on the main screen for mark geometries layer.

Cutting : change the color used for display on the main screen for cutting geometries layer.

Background : change the color used for background main screen color
Context Menu

Can be accessed with a mouse right click in the main application window. No new functions are implemented here. Each context menu function represents a shortcut to specific menu item. The icon used for each item is shown also in the menu and corresponding toolbar items.

Main Display Window:
The large center window displays the geometry of the path. The left tree view control show the nested parts. Colors are used to distinguish between the different functions of the geometric entities. The DXF object colors can be changed on the Layer tab in Tools->Preference, and SoftONE generated object colors can be changed from Tools->Option menu.
Information Window:
Display the production information.

<table>
<thead>
<tr>
<th>Nesting info</th>
<th>Nesting Dimensions</th>
<th>X:</th>
<th>Y:</th>
<th>Burning Length</th>
<th>Marking Length</th>
<th>Labelling Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ready</td>
<td>Coordinates: X: 1144.4 Y: 2706.2</td>
<td>Max: 9140 MaxT: 240</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The following information are available:
- Nesting dimensions
- Nesting Quality
- No of Parts
- Idle length
- Burning length
- Marking length
- Labelling length
- Coordinates of the current mouse point on the screen.

Toolbars

Each button represents a shortcut to a menu item. The icon used for each toolbar is shown also in the menu at the corresponding function. No new functions are implemented here. Some task of “Edit” menu function can be accessed only from “Edit” toolbar: Change Leads Angle -> Rotate Clockwise, Change Leads Angle -> Rotate counterclockwise and Change Leads length -> Increase Lead Length and Decrease lead length.

A tool tip (a text message that describes the function of the button) appears if you rest the cursor over a button for a short time.